warp-cli connect. Connection reset by xxxxxx port 22.

$ 6

Ubuntu 22.04

Install Cloudflare WARP.

curl -fsSL https://pkg.cloudflareclient.com/pubkey.gpg | sudo gpg --yes --dearmor --output /usr/share/keyrings/cloudflare-warp-archive-keyring.gpg

echo "deb [signed-by=/usr/share/keyrings/cloudflare-warp-archive-keyring.gpg] https://pkg.cloudflareclient.com/ $(lsb_release -cs) main" | sudo tee /etc/apt/sources.list.d/cloudflare-client.list

sudo apt-get update && sudo apt-get install cloudflare-warp

Initial Connection.

warp-cli register

When I run warp-cli connect, it stutters for a long time and then the server connection drops.

When I try to ssh into the server again, I get the following error message:

kex_exchange_identification: Connection closed by remote host

Connection reset by xxxxxx port 22

Check the status of port 22 on the server.

nmap -p 22 IP


22/tcp open ssh

nc -vz IP

Connection to IP port 22 [tcp/ssh] succeeded!

I've tried restarting the server and still can't ssh into the server.

  • name1989


    warp-cli proxy port 端口号


    不过你说的这种情我之前遇见过,那是下面文章中的第二种方式(WireGuard),这个时候你可以通过vnc登录,ping google.com会发现是失败的,想要拯救你的机器可以kill掉你认为导致失败的事物。


  • name1989
  • Ethan

    Ethan Author

    还没到设置端口的那一步。 就根据官方文档,安装、注册完,执行连接命令的时候,发生了这样的事情。 Initial Connection

  • Ethan

    Ethan Author

    Message from FloppyDisk.



    If you are managing the deployment remotely over SSH, your connection may drop when you register the WARP connector. Because the connector immediately starts forwarding traffic to Cloudflare, the remote SSH server’s traffic will be routed to Cloudflare instead of via the server’s public IP and will timeout your existing connection. You can work around this issue by temporarily adding the public IP of your local machine to your Split Tunnel Exclude list.

    As mentioned in the doc you lost connectivity when the warp tunnel went up, exclude your private network in the split tunnel config as mentioned in the doc

  • Ethan

    Ethan Author

    VNC login.

    warp-cli disconnect

This question has been resolved and no bounty will be distributed.